Support Forum Softcomplex logo
About Us  | Services  | Download  | Order  | Support  | |
| Search | Today's Posts | Stats | Board Rules | Not logged in [ Login | Register ]
go to bottom
Last active: Never

Printable Version | Subscribe | Add to Favourites   Post new thread
Author: Subject: IE 6 losts calendar after postback ver 4
vipasane
Junior Member

Posts: 2
Registered: 1/9/2009
Member Is Offline
posted on 1/9/2009 at 04:32 PM Reply With Quote
IE 6 losts calendar after postback ver 4


I have been using new version of Tigra calendar and it's working fine, but something weird is happening with IE 6:

I have web application made with asp.net 1.1 and when I first load the page calendars work fine (except wrong today date ;)) since I have validators in page and for some reason page is not valid and you'll have to fix it before you can continue.
So a postback occurs and you'll return back to the same page.
This works fine with opera and FF3
IE 6 will run javascript constructor new tcal(...) correctly (I have planted few alerts here and there) but nothing is shown on the form afterwards.
To make it even trickier I found out that I been using it in 3 pages and with one of them it will work.

Is there anything you could suggest to fix this?
View User's Profile View All Posts By User U2U Member
billboyle4
Newbie

Posts: 1
Registered: 5/1/2009
Member Is Offline
posted on 5/1/2009 at 08:04 PM Reply With Quote
Possible Fix


I have the same problem. I am going to try the following:

function tcal (a_cfg, a_tpl, a_div) // add in a_div

and inside this function change the document.write to:

document.getElementById(a_div).innerHTML = ('<img...

and then move all of the javascript constructors into a function called by document.onLoad, and add some div's where I want the controls to go. I'll let you know how it goes...
View User's Profile View All Posts By User U2U Member
Post new thread

Related Links:
Product Page
Product Demonstrations Live Demos
Free Download Free Download
Product Documentation Documentation
Support Forum Support Forum
 

Go To Top


Powered by XMB 1.9.1 Nexus
Developed By Aventure Media & The XMB Group © 2002-2004