Support Forum Softcomplex logo
About Us  | Services  | Download  | Order  | Support  | |
| Search | Today's Posts | Stats | Board Rules | Not logged in [ Login | Register ]
go to bottom
Last active: Never

Printable Version | Subscribe | Add to Favourites   Post new thread Poll:
Author: Subject: [IE 6][Frames] Slider disappear on resize
Guillaume
Junior Member

Posts: 5
Registered: 11/28/2006
Location: France
Member Is Offline
posted on 11/28/2006 at 07:26 AM Reply With Quote
[IE 6][Frames] Slider disappear on resize


Hi,

I am experiencing trouble with the slider.
Everything is working fine as long as I do not resize the frames. In this case (and others like maximizing the window), the slider disappears.
This, I have to refresh the frame containing the slider and it re-appears.

I thought it was due to a bad 's_form' parameter but I was unsucessful with this.

Has anybody experienced the same ?

Thanks in advance.

Best regards,
Guillaume
View User's Profile View All Posts By User U2U Member
Guillaume
Junior Member

Posts: 5
Registered: 11/28/2006
Location: France
Member Is Offline
posted on 11/29/2006 at 03:53 AM Reply With Quote
Damned <span> !!


Hi,

I found out the problem.
When you embed a slider in a <span> and then in a <table>, then the slider disappears when maximizing the window or when resizing a frame within a frameset.

I attached a simple example of this in this post.

Hope for a fix very soon !! :-)

Best regards,
Guillaume

Attachment: span_bug.htm (1.96kb)
This file has been downloaded 841 times
View User's Profile View All Posts By User U2U Member
tigra
Administrator

Posts: 2049
Registered: 6/17/2002
Location: US, CO
Member Is Offline
posted on 11/30/2006 at 08:40 AM Reply With Quote

The <span> is inline element while <table> is block element. Block elements should not be included in inline elements.
View User's Profile View All Posts By User U2U Member
Guillaume
Junior Member

Posts: 5
Registered: 11/28/2006
Location: France
Member Is Offline
posted on 11/30/2006 at 09:18 AM Reply With Quote

Hi,

Thanks for your answer.
Thus, if I follow your idea, this should work with <div> instead of <span> since <div> is the generic block element.
=> the slider disappears yet again ??

Is the example still badly-formed ?

Best regards,
Guillaume
View User's Profile View All Posts By User U2U Member
tigra
Administrator

Posts: 2049
Registered: 6/17/2002
Location: US, CO
Member Is Offline
posted on 11/30/2006 at 02:14 PM Reply With Quote

problem here is caused by "position:relative", not by the DIV tag itself.
View User's Profile View All Posts By User U2U Member
Guillaume
Junior Member

Posts: 5
Registered: 11/28/2006
Location: France
Member Is Offline
posted on 12/1/2006 at 01:31 AM Reply With Quote

Hi,

It's OK now !
Thanks for your time solving this issue ! :-)

Best regards,
Guillaume
View User's Profile View All Posts By User U2U Member
Post new thread Poll:

Related Links:
Product Page
Product Demonstrations Live Demos
Multiple Designs
Equalizer
Free Download Free Download
Product Documentation Documentation:
Documentation Page
Change Log
Support Forum Support Forum

Go To Top


Powered by XMB 1.9.1 Nexus
Developed By Aventure Media & The XMB Group © 2002-2004