Support Forum Softcomplex logo
About Us  | Services  | Download  | Order  | Support  | |
| Search | Today's Posts | Stats | Board Rules | Not logged in [ Login | Register ]
go to bottom
Last active: Never

Printable Version | Subscribe | Add to Favourites   Post new thread
Author: Subject: Javascript error 'TM0_ is undefined'
jim2ee
Junior Member

Posts: 2
Registered: 10/19/2005
Location: England
Member Is Offline
posted on 11/3/2005 at 09:15 AM Reply With Quote
Javascript error 'TM0_ is undefined'


I just upgraded to Tigra Menu Gold and this error is driving me nuts. I'm working in Websphere Application Developer.

All menu files are in my directory TigraMenuGold.
------------------------------------------------------------------
menu.js:
var TMenu_path_to_files='TigraMenuGold/';

var menus=[],TM1E,TMF.... etc

I've also tried '/TigraMenuGold/' and '../TigraMenuGold/'
------------------------------------------------------------------
html file:

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<HTML>
<HEAD>
<META http-equiv="Content-Type" content="text/html; charset=ISO-8859-1">
<META name="GENERATOR" content="IBM WebSphere Studio">
<TITLE></TITLE>
<link rel="stylesheet" href="../TigraMenuGold/menu.css">
<script language="JavaScript" src="../TigraMenuGold/menu.js"></script>
<script language="JavaScript" src="../TigraMenuGold/left_menu_items.js"></script>
<script language="JavaScript" src="../TigraMenuGold/template.js"></script>
</HEAD>
<BODY>
<script language="JavaScript">
new menu (MENU_ITEMS, MENU_TPL);
</script>
</BODY>
</HTML>
-------------------------------------------------------------------
Any help would be greatly appreciated.
View User's Profile View All Posts By User U2U Member
tigra
Administrator

Posts: 2049
Registered: 6/17/2002
Location: US, CO
Member Is Offline
posted on 11/11/2005 at 05:17 AM Reply With Quote

Usually this error means that the path in menu.js is incorrect. I see you tried several different options, but probably none of them are correct. Submit the support ticket providing the URL of your webpage and we'll recommend you the settings.
View User's Profile View All Posts By User U2U Member
rdleeper
Junior Member

Posts: 3
Registered: 2/28/2006
Member Is Offline
posted on 11/28/2006 at 10:51 AM Reply With Quote

I had the same problem. While I can't confirm this as I have tried many things and now don't want to "break" a working solution....try running unix2dos or dos2unix on your menu*.js files. I am doing development on Windows (apache/Weblogic) and deploy to Linux.

I was having problems on my dev box. I was going to submit a support ticket and reference the working files on my public web site (linux). However, when I pushed my test case to the linux box...it worked without any changes. I then thought of previous errors I had had with migrating files between Windows/Unix and remembered the dos2unix/unix2dos utilities.

Another thing to check is the file permissions on your files at the web server. Double check your error logs to see if any file permission errors are being logged. This helped as well.

This may or may not be the solution as I had tried many things at once. If you do tryit ...keep a backup of your files before you try.

Hope it helps.
View User's Profile View All Posts By User U2U Member
Post new thread

Related Links:
Product Page Product Page
Functionality demos Functionality demos
Multiple
Cross-framed
Select-boxes
Effects
Design demos Design demos
Icons & arrows
Idea!
Hi there!
Matrix
MS Style
XP Style
Dots
3D-Buttons
Product Documentation Documentation
Documenation Page
Change Log
Menus Comparison Table
Support Forum Technical Support
Support Forum
Customer Care System
Order Now ORDER NOW!
Add to Cart
View Cart
 

Go To Top


Powered by XMB 1.9.1 Nexus
Developed By Aventure Media & The XMB Group © 2002-2004