Support Forum Softcomplex logo
About Us  | Services  | Download  | Order  | Support  | |
| Search | Today's Posts | Stats | Board Rules | Not logged in [ Login | Register ]
go to bottom
Last active: Never

Printable Version | Subscribe | Add to Favourites   Post new thread
Author: Subject: PHP Safe mode
Druen
Newbie

Posts: 1
Registered: 7/12/2006
Location: asklsasa
Member Is Offline
posted on 7/12/2006 at 03:39 AM Reply With Quote
PHP Safe mode


Hi

Can't event calender run in PHP Safe mode?

I get the following error after the installation:

Warning: session_save_path(): SAFE MODE Restriction in effect. The script whose uid is 60026 is not allowed to access owned by uid 0 in /customers/marxist.dk/marxist.dk/httpd.www/kalender/cl_files/index.php on line 10

Warning: session_start(): Cannot send session cache limiter - headers already sent (output started at /customers/marxist.dk/marxist.dk/httpd.www/kalender/cl_files/index.php:10) in /customers/marxist.dk/marxist.dk/httpd.www/kalender/cl_files/index.php on line 11

Warning: main(cl_files/calendar.php): failed to open stream: No such file or directory in /customers/marxist.dk/marxist.dk/httpd.www/kalender/cl_files/index.php on line 25

Warning: main(): Failed opening 'cl_files/calendar.php' for inclusion (include_path='.:/usr/lib/php') in /customers/marxist.dk/marxist.dk/httpd.www/kalender/cl_files/index.php on line 25

Fatal error: Call to undefined function: read_data() in /customers/marxist.dk/marxist.dk/httpd.www/kalender/cl_files/index.php on line 27
View User's Profile View All Posts By User U2U Member
chronister
Member

Posts: 23
Registered: 8/24/2006
Member Is Offline
posted on 8/27/2006 at 09:04 PM Reply With Quote

This sounds like an issue for the Web Host.

I changed my homeserver's php.ini file to safe_mode=ON and the calendar runs just fine.

I am new to PHP and all, but it seems that the webhost is blocking access to the php session directory.

There may be other items in your web hosts php.ini file that they have changed, but simply the safe_mode part is not causing your problem as I even did a phpinfo() to confirm that it was running in safe mode. Sorry I could not be of more assistance.

Nathan Chronister
View User's Profile View All Posts By User U2U Member
Post new thread

Related Links:
Product Page
Product Demonstrations Live Demos
Free/Trial Script Download Free Download
Product Documentation Documentation
Documentation page
Change Log
Support Forum Support Forum
Order Now ORDER NOW!
Add to Cart
View Cart
 

Go To Top


Powered by XMB 1.9.1 Nexus
Developed By Aventure Media & The XMB Group © 2002-2004