Board Logo

Fader script inside table problem
Samba - 3/6/2008 at 07:51 PM

I have a problem when using the script inside a table in IE, it works fine in FF.

I get a scroll that messure the width of all images. Still
there is only one image showing. Have tried changing tje z-index but without any luck

any help would be use full


tigra - 3/6/2008 at 10:19 PM

try using table with the sample from the distribution package.
do you experience the same problem? anything is different in your case?


leouy90 - 3/9/2008 at 05:08 PM

making a new html file with the tFader script
and next put a iframe

<iframe id="tFader" src="http://yourdomain.com/tfader.htm" width=405 height=238 marginwidth=0 marginheight=0 hspace=0 vspace=0 frameborder=0 scrolling=no></iframe>


s814jjs - 4/11/2008 at 06:21 PM

I had the same problem, but didn't want to use iframes, so this is what I came up with:

Update the style definitions inside tFloat.js for the <img> tag - replace "position:relative" with "positon:absolute".

It now works fine for me in both browsers.

SoftComplex - thanks for writing and releasing this code!!!


brough - 2/10/2009 at 02:14 PM

Quote:
Originally posted by s814jjs
I had the same problem, but didn't want to use iframes, so this is what I came up with:

Update the style definitions inside tFloat.js for the <img> tag - replace "position:relative" with "positon:absolute".

It now works fine for me in both browsers.

SoftComplex - thanks for writing and releasing this code!!!


Typo there: s814jjs is referring to tFader.js - and yes, that's the solution to having Fader work within tables in IE. Just modify the js to read
style="position:absolute;

Great script!


Softcomplex: http://www.softcomplex.com/
Back to forum: http://www.softcomplex.com/forum/