Board Logo

Missing nodes if I execute tree menu more than once
bradleycarmody - 8/13/2007 at 09:09 PM

I am using the tree menu within my ColdFusiion application. After a lot of work I finally got it to work - yeah!! I build my tree items dynamically. My problem is when I execute the tree several times the level one nodes appear and the first couple of second level nodes appear but if I have several level one nodes the second level node does not always appear. I don't think the problem is with building the tree items because it will work great if I get out of IE and back in again and run the exact same search. To sum it up if I run the tree more than once I could get strange results and not all nodes appear unless I close out of IE and back in again.

I have tried refreshing the page, deleting cookies, deleting temporary files. The only way to get the tree "cleared out" is to close out of IE and log back into my application.


tigra - 8/13/2007 at 10:10 PM

do you experience the same problem with static (as opposed to dynamically generated) tree_items.js file?


bradleycarmody - 8/15/2007 at 03:27 PM

If I just "hard code" in the tree items it works fine but the application does not use the tree as static. The tree is built dynamically and populated based on a search criteria.

The first time always works fine. It is subsequent calls that I sometimes have problems with. The root node displays but does not expand so you don't know if there is a second node with more data. I would like the root icons to always be expanded. I realized that the second nodes are there but you have to double click on the root node each time to expand.

Attached is an example of what the tree looks like - you will notice the icon with the school houses do not show the book icons below with.

Thank You


tigra - 8/15/2007 at 11:40 PM

Do your "subsequent calls" reload the page with the tree?


bradleycarmody - 8/16/2007 at 04:12 PM

I got it to work by defining the tree item scope setting {'st':1}


Softcomplex: http://www.softcomplex.com/
Back to forum: http://www.softcomplex.com/forum/