Board Logo

Validation problems
dmx3000 - 8/28/2007 at 04:18 PM

Hi,

I am new to this and came upon Tigra Hints by chance - it was just what I wanted. Trouble is using XHTML 1.0 Transitional when I try to validate it I get errors everywhere. I tried validating sample3 supplied with the zip and that came up with 25 errors.

Probably the most worrying is the section:
var HINTS_ITEMS2 = {
'tt1':
when it complains about having the image reference here. Can I ask how other people have overcome these.

Thank you


tigra - 8/28/2007 at 07:11 PM

any other problems other than validation errors? Your validator may not be able to understand that the HTML is the part of the JavaScript string and it's not of its concern.


dmx3000 - 8/29/2007 at 04:14 PM

Thanks for replying. I use the W3C Markup Validation Service. As I said this seems a great product and I can resolve most of the missing 'alt' etc, it's just this thing about
var HINTS_ITEMS2 = {
'tt1':<img blah><div>adding text under image</div>
(from reading the forum) adding text under the image in a DIV also brings up an error.

Hope this has explained it better

Regards


tigra - 8/29/2007 at 05:23 PM

As I mentioned in my last response, whatever is between <script> and </script> is not markup validator's concern. JavaScript is not a W3C markup language. My bet that there is no real problem, just inability of the validator to understand its scope of responsibility.


dmx3000 - 8/30/2007 at 08:46 AM

Again thanks.

Problem solved anyway - I just put all the body script in an external js file, effects work and no validation problems.

Thanks for taking the time


Softcomplex: http://www.softcomplex.com/
Back to forum: http://www.softcomplex.com/forum/