Board Logo

Menu Builder - Can't delete style / delete's wrong style
Bewildered - 3/26/2007 at 08:52 PM

I created two styles - Style 1 and Style 2. Then I wanted to delete them both.

I deleted Style 1, no problem. But then I couldn't delete Style 2, even after going to other tabs an returning to the Style tab. When I clicked on [delete] for Style 2, nothing happend.

Finally, I created Style 1 again, this time as a copy of blue grades - root level. Then I clicked on [delete] for Style 2, and this time it asked me if I wanted to delete Style 1. Not style 2, stlye 1! I said yes, and it deleted stlye 1 and didn't touch style 2, even though I had definitely clicked on [delete] for style 2, not stlye 1.

I can edit Style 2 -- including changing its name -- and I can move it up or down. But I can't delete it.

This remains true even after saving the project, closing the browser, opening Menu Builder again and reloading the project.

Here are the CSS settings from the Export page. Style 2 does not appear, even though it is named that on the Styles page.

/* blue grades - root level; text properties for states: normal, hover, click */
.TM0i0 {
font-family: Tahoma, Verdana, Geneva, Arial, Helvetica, sans-serif;;
color: #FFFFFF;
font-size: 12px;
font-weight: normal;
font-style: normal;
text-decoration: none;
}

/* blue grades - root level; box properties for states: normal */
.TM0o0 {
background: #3C76B2;
padding: 4px;
text-align: center;
vertical-align: middle;
text-decoration: none;
}

/* blue grades - root level; table properties for states: normal, hover, click */
.TM0t0 {
background: #2B547F;
}

/* blue grades - root level; box properties for states: hover, click */
.TM0o1 {
background: #4D99E6;
padding: 4px;
text-align: center;
vertical-align: middle;
text-decoration: none;
}

/* blue grades - sub levels; box properties for states: normal */
.TM1o0 {
background: #4D99E6;
padding: 4px;
text-align: left;
vertical-align: middle;
text-decoration: none;
}

/* blue grades - sub levels; box properties for states: hover, click */
.TM1o1 {
background: #3C76B2;
padding: 4px;
text-align: left;
vertical-align: middle;
text-decoration: none;
}


Suggestions?

Bewildered.


tigra - 3/27/2007 at 04:32 AM

check if this style is used by any levels (second form on the right at the "items" tag)


tigra - 3/27/2007 at 04:51 AM

also when you have more than one style try moving the style down and then deleting


Softcomplex: http://www.softcomplex.com/
Back to forum: http://www.softcomplex.com/forum/