Board Logo

menu in table
nedlilly - 10/3/2006 at 03:29 PM

I've purchased the Gold product, and am still trying to get my menu (which works fine on the test page) to work within a table cell.

Here's the code for the row in this table:

<tr>
<td background="/images/leftborder.jpg"><img src="images/shim.gif" width="5" height="1"></td>
<td><a href="/"><img src="/images/top_01_logo.gif"></a></td>
<td width="100%" background="/images/top_01_shadebg.gif">
<img src="images/shim.gif" width="1" height="1"></td>
<td><img src="/images/top_01_blueCorner.gif"></td>
<td background="/images/top_01_bluebg.gif">
<script language="JavaScript">
new menu (MENU_ITEMS, MENU_TPL);
</script>
</td>
<td background="/images/rightborder.jpg"><img src="/images/shim.gif" width="5" height="1"></td>
</tr>

We purchased Tigra Menu Gold specifically for the ability to do relative positioning of a menu inside a table.

Any clues on what I'm doing wrong?

Thanks,
Ned


tigra - 10/3/2006 at 10:12 PM

Make sure you enabled the relative positioning by removing block_top and block_left parameters from the root level configuration in template.js

If you did that and still experience the problem then submit a support ticket attaching all the files needed to reproduce the problem in the zip package.


nedlilly - 10/4/2006 at 03:07 PM

FYI to anyone who finds this thread: I got the following reply from support...

---

since the menu files are not in the default location you should update the paths accordingly. In menu.js replace
var TMenu_path_to_files='menu_files/';
with
var TMenu_path_to_files='test/menu_files/';

---

It worked, so thank you support. I didn't see the TMenu_path variable in the docs, so hope this might help someone else in the future.


Softcomplex: http://www.softcomplex.com/
Back to forum: http://www.softcomplex.com/forum/