Board Logo

Opera 8.52 submenu problem
fromano2802 - 4/25/2006 at 09:40 AM

Hi there,

I am using Tigra Menu Gold for a new website. The web site will be tableless and the menu is in a right floating class element embedded in an overall wrapper.

If I open the web site with IE and Firefox, the layout works fine, but if I use Opera 8.52, the submenus pop up about fifty pixel below the Tigra menu (they should be right below the menu).

Any thought?

Thanks,

fromano2802


tigra - 4/27/2006 at 01:25 AM

Do you experience the same problem with online demonstrations or with the samples from the distribution package? If you do then the problem is in your page and/or menu configuration. Try to debug and submit a support ticket if nothing helps.


fromano2802 - 4/27/2006 at 08:09 AM

Hi there,

this is the code I am using. You can try it with all the examples included in Tigra menu gold. I tried it with 'dots' and 'Matrix' and the issue was there.
I hope this helps.



<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" />
<title>Untitled Document</title>
<script language="JavaScript" src="menu_files/menu.js"></script>
<script language="JavaScript" src="menu_files/items.js"></script>
<script language="JavaScript" src="menu_files/template.js"></script>
<link href="menu_files/menu.css" rel="stylesheet" type="text/css" />
<style>
body {
font: 100% Verdana, Arial, Helvetica, sans-serif;
font-size: 10px
color: #000000;
text-align: center;
margin: 40px 0px;
padding: 0px;
}

#outside_wrapper {
text-align: left;
margin: 0 auto 0 auto;
width: 800px;
}

#inside_wrapper {
background: #ffffff;
width: 800px;
border: 1px solid #f0027f;
padding: 5px;
}

#header {
height: 173px;
}

#top_menu {
float: right;
margin: 125px 0 0 0;
padding: 0px;
height: 25px;
width: 566px;
background-color: #000000;
}
</style>
</head>
<body>
<div id="outside_wrapper">
<div id="inside_wrapper">
<div id="header">

<div id="top_menu"> <script language="JavaScript" type="text/javascript">
<!--
new menu (MENU_ITEMS0, MENU_POS0);
//-->
</script> </div>
</div>
</div>
</div>
</body>
</html>


tigra - 4/28/2006 at 12:24 AM

What about the original samples (with their own HTML documents)? Do they work ok? If they do then something in this HTML code triggers the problem. Try commenting out the fragments to see which one affects the menu.


fromano2802 - 4/28/2006 at 07:52 AM

The samples with their own HTML work.

I think that the problem is triggered by the fact that the menu is inside a FLOAT element, because, if I put the menu outside it, it works fine.
You can try yourself you like.

Is there any parameter I have to tweak in order to make it work right?


Softcomplex: http://www.softcomplex.com/
Back to forum: http://www.softcomplex.com/forum/