Board Logo

Why doesn't it work online? II
meh - 4/14/2005 at 12:28 AM

Hello everybody !

First thanks a lot for these very nice tigra-scripts !! But I have a problem, I discover this forum today to look if I find an solution to this prob, but unfortunately I did not. Maybe I was not careful enough ? :))

So, my problem is this:

Everythings ( scrolling vertical) works offline on my pc very fine, without problem after changes in cont1.html and cont2.html ...But after uploading everything, the scrolling does not work online on my NGO-website. And I still don't understand why ! I tried too to upload the original script without changing nothing, and then the same : works fine offline, but not online anymore (MIE and Firefox). Only the table-header is to see, but the scroller-window is very little without scrolling anything.

...It would be so nice to have a solution, thanks a lot for answers !


rock - 4/14/2005 at 06:47 AM

Please mention URL of the site.


meh - 4/14/2005 at 10:09 AM

thanks for the reaction:))

The url is :

http//:www.bapob.de

As written, everythings working very fine offline, nut online not.


meh - 4/14/2005 at 10:11 AM

Ok, I forgot to write: it is the index-page, and the scroller should be there where you see the table-header called here "AnkA?ndigungen" in the really middle of the page.


rock - 4/15/2005 at 07:00 AM

Please check scroll.tpl0.js formating. Seems end-line charachters are missing.


meh - 4/15/2005 at 10:17 AM

Thanks a lot for again your quick answer !

After reading what you wrote secondly, it seems that the comments were not ok in the original scroll.tpl0.js, my editor did not informed me about it but now it is working on MIE, what is good ...but unfortunately not on Firefox (!) although it
still theorically works offline and : there are now much more errors written in the Firefox-Javascript-Console ! Why ?!!Have to look... If you know something, please tell me

Sincerely


rock - 4/15/2005 at 11:12 AM

I don't see any JS errors at FF0.9.3 - FF1.0.2
Scroller works just fine.


meh - 4/15/2005 at 11:35 AM

Thanks Rock to look at. But it is really strange : on my pc it does not work, and there were still all these javascript errors noticed on the Firefox-JS-Console ( v.1.02) :


ErreurA?: BEHAVE is not defined
Fichier SourceA?: http://www.bapob.de/ts_files/scroll.html?0
LigneA?: 30


ErreurA?: main is not defined
Fichier SourceA?: http://www.bapob.de/ts_files/scroll.html?0
LigneA?: 67


ErreurA?: invalid property id
Fichier SourceA?: http://www.bapob.de/ts_files/scroll.tpl0.js
LigneA?: 1, ColonneA?: 200
Code SourceA?:
/ to be able to estimate item sizes 'file': '../s0_data/cont2.html', 'content': '', 'pause_b': 0, 'pause_a': 0 }, { 'file': '../s0_data/cont1.html', 'content': '', 'pause_b': 0, 'pause_a': 0 }]



I ask my server why it does not working on first either on MIE or in Firefox, and he wrote me first there is some kind of trouble with this file, because when we open it with an editor it looks like well, but when uploaded it to the server, or a copy & paste (like this below) it is all put in one line, like:

var LOOK = { // scroller box size: [width, height] 'size': [300, 60] }, .......

and the first comment, comments all the rest of the file, there is the problem.
...So, I change it and put the comments outside the {} of the script. After it, it was working fine on MIE, but still not on Firefox, although it always still works offline !


Second, my server wrote after it too that the script was created with an Apple, that at the end line of a Mac is a CR code only. He proposed me to upload himself a scroll.tpl0.js with the correct newline caracters, because he has seen that his UNIX editor handles well the conversion from Mac to Windows or UNIX.
And only now it working fine on Firefox at him and at me.

What do you think about it ?

Regards


meh - 4/15/2005 at 11:37 AM

and : working now finally on Firefox fine, but still with the same javascript-errors on the JS-Console...


rock - 4/15/2005 at 12:09 PM

Try to clear the FF browser cache.


meh - 4/15/2005 at 12:18 PM

Ok, you're right, I've done it. No errors anymore.

But what are you thinking about the other issues, that with "var LOOK = { // scroller box size: [width, height] 'size': [300, 60] }, ......." and " Mac CR code" ?


rock - 4/15/2005 at 12:26 PM

I'm afraid I can't exactly point you the reason of the issue, our users have never mentioned about such problems before.


meh - 4/15/2005 at 01:08 PM

hmm, ok, but it is quite interesting, no ? Do you think it is possible the problem was coming from the server ? Was the script really written on Mac as my server told me ?


rock - 4/15/2005 at 02:14 PM

The scripts are witten on Windows platform. Our original package formating is CR+LF


Softcomplex: http://www.softcomplex.com/
Back to forum: http://www.softcomplex.com/forum/