Board Logo

First calendar displayed by default
analog2112 - 12/1/2007 at 12:17 AM

Hi,

I'm having problem which is probably something simple, but I just can't see it.

I'm using the Pro Product in modal_multiple mode and I'm having a problem with the 1st calendar on the page.

The page draws out 10 calendars, calendars 2 - 9 work fine (popup comes up, date goes into the correct input).

Calendar 1 is always displayed on the page (from page load on). If I click the icon for calendar 1 it will toggle the black X on and off like it should. But the calendar never disappears.

It appears on the page at the bottom of it in the same spot as the array creation script.
<script language="JavaScript">
for (var n = 0; n < A_CALENDARS.length; n++) {
A_CALENDARS[n].create();
}
</script>


"var CAL_INIT starts" at 1 (var CAL_INIT1 for the 1st calendar) and "new calendar(CAL_INIT" is the same (new calendar(CAL_INIT1) for the first one).

It does the same thing in IE 7 and FF 2. Sorry I can't provide a URL as the page is behind auth.

Any ideas?

BTW - Its an excellent product, can't think of any other functionality I could every want!

Thanks
-Chris


tigra - 12/5/2007 at 08:15 PM

please create the simple demo of the problem (client files only), zip files and attach the package to the support ticket.
we'll investigate the problem and send you back the corrected version. most likely something in configuration.


Softcomplex: http://www.softcomplex.com/
Back to forum: http://www.softcomplex.com/forum/