Board Logo

bug in calendar
ariel - 10/27/2008 at 06:52 PM

when text is not empty and I clic on calendar icon month layout is wrong. ie: today is monday and calendar show thuesday. When the text box is empty show calendar perfect.

ariel has attached this image:


tigra - 10/27/2008 at 10:50 PM

It looks like you use firefox, but I couldn't reproduce the problem on my end.
Any specific way to get there?


onagrosan - 12/4/2008 at 12:33 PM

Same happens to me: Calendar empty date, today is OK; calendar filled, today shows "today plus 1 day". Even with your site live demo. I use IE 7, by the way.

Maybe related to the fact I am located in Spain now?


tigra - 12/4/2008 at 03:35 PM

We've redesigned the calendar from the scratch. New version 4.0 was released on 12/01/2008
Do you experience this problem with new version as well?


ariel - 12/4/2008 at 06:19 PM

month in October lost configuration order in days.


tigra - 12/4/2008 at 06:29 PM

this looks like previous version. try the latest version and see if you still experience the problem.


marshallartsoz - 1/13/2009 at 02:23 AM

I'm having this problem, with version 4.0.1. (European variation) If the date textbox is empty, all is OK - the calendar shows the current date highlighted with the background colour AND with the red box. But if there is a (valid) date in the textbox when the calendar icon is clicked, then the correct date is shown with the background colour, but the red box is around tomorrow's date, not today's. Definitely a problem somewhere.


tigra - 1/13/2009 at 04:08 AM

Fixed. Download 4.0.2


lambe - 4/27/2009 at 03:43 PM

the problem continue.

month December appear when I click twice in '>' button and in some case the day in this month is incorrect. Even with your site live demo.

a day in month December exactly problem decribed in other post.

I use version 4.0.2


tigra - 4/27/2009 at 05:14 PM

Please provide your local date and time at the moment of testing. Also your time zone, browser name and version.


lambe - 4/27/2009 at 05:34 PM

My local time is dd/mm/yyyy (GMT -3)

I tested in Firefox 2.0.0.20 / 3 and IE 6 / 7 in different machines.


tigra - 4/27/2009 at 10:56 PM

I can't reproduce the problem on my computer in different browsers. What are the exact steps I need to take to get the results you're getting?


grobmotoriker - 7/23/2009 at 02:50 PM

Ok, this does not really belong to a possible bug in the calendar, but maybe it also helps:

I also used the Tigra calendar and I got the same problem like reported above: the month value was one month before the selected date - I finally found out that this hasn't been a problem with the calendar, but with the PHP function strptime, which returns the month in the range 0 to 11. :-|


Softcomplex: http://www.softcomplex.com/
Back to forum: http://www.softcomplex.com/forum/