Board Logo

Menu Pro with asp?
tk1101 - 8/11/2003 at 09:25 PM

I'm in the process of moving my site and because of no perl support on the new one, I'm replacing my guest book with an asp version. I set the relative path to the js files and the menu.css and everything is working fine except that pixel.gif isn't displaying. I've tried putting another copy of pixel.gif in cgi-bin, but that's not helping. Anyone know how to fix?

I've got this code:


<script language="JavaScript" src="../menu.js"></script>
<script language="JavaScript" src="../menu_items.js"></script>
<script language="JavaScript" src="../menu_tpl.js"></script>
<script language="JavaScript">
<!--//
new menu (MENU_ITEMS, MENU_POS);
//-->
</script>


rock - 8/12/2003 at 08:48 AM

Have you modified setting
MENU_POS['pixel_path'] = 'pixel.gif';
in your menu_tpl.js file?


tk1101 - 8/13/2003 at 06:33 PM

No, because pixel.gif is in the root directory of the account. I tried specifying it in menu_tpl.js file by machine path (info provided by the host co.), but it returns an error with that format. The menu_tpl.js file and pixel.gif are in the same directory. Can I give it a hard path such as http://www.myaddress.com/pixel.gif ?


Quote:
Originally posted by rock
Have you modified setting
MENU_POS['pixel_path'] = 'pixel.gif';
in your menu_tpl.js file?


rock - 8/14/2003 at 12:02 PM

You should define pixel.gif path as:

MENU_POS['pixel_path'] = '../pixel.gif';


Softcomplex: http://www.softcomplex.com/
Back to forum: http://www.softcomplex.com/forum/