Board Logo

Form elements and Flash movies behind the menu
donaldsa - 8/13/2002 at 08:52 PM

When I mouseover my menus the sub menus come up fine. However, they are drawn behind other elements on my page. How do I ensure that when the menus popup, they will always be on top of everything.

Don Sanders

tigra - 8/14/2002 at 06:28 AM

Tigra Menu PRO items are normally displayed in topmost layers leaving the content behind, except few cases.

From Tigra Menu PRO FAQ:

Q: How do I ensure that menus display on top of the HTML form elements?
A: Unfortunately, this is common problem with windowed controls (html listboxes, flash movies) and absolutely positioned html elements (all types of cross browser javascript menu systems).

Tigra Menu GOLD v2.0+ has work around for form elements related problem. See demo at:

woodwater - 8/20/2002 at 06:38 PM


As far as Flash movies are concerned you just need to insert this parameter in the code of the movie and the Tigra Menu will display on front:

<param name="wmode" value="transparent">



joeknix - 10/11/2002 at 02:14 PM

Thank you woodwater you are a lifesaver. I was using a flash effect and your param name suggestion worked like a charm.

jennyfur - 5/19/2003 at 04:01 PM

Unfortunately, adding that param name code will only make the menu show above the flash in IE 5+ or Netscape 7+ (not sure about IE versions earlier than 5 since I didn't have any to test with).

Earlier versions of Netscape still show it behind the flash since they don't seem to be able to support transparent flash movies. So that pretty much means that any version of Netscape other than the very recent one will not show the menu, unless someone has some other suggestion.

Using the same workaround that was used for hiding form elements doesn't seem to do anything for flash. By the way I'm using tigra menu GOLD 2.0

Help would be appreciated.

dstoltz - 2/16/2004 at 03:26 PM

Yes, I agree - this does not help with FLASH....Even using Netscape 7.1 the menu appears behind the flash....

tigra - 2/16/2004 at 10:53 PM

Unfortunately this is something that can't be changed with client side code. If any better solution found we'll embedd it into our scripts.

dstoltz - 2/17/2004 at 01:25 PM

After checking into this problem, simply using the following code will not work for netscape:

<param name="wmode" value="transparent">

That is because that parameter is part of the OBJECT tag, which is only used by IE. Netscape uses the EMBED tag, so you need the above code for IE, and the following code inserted into the embed tab as another parameter:


See this site for more details - but it works for me.

The entire code should look something like this:

<object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" codebase=",0,29,0" width="400" height="100">
<param name="movie" value="images/newservices.swf">
<param name=quality value=high>
<param name="wmode" value="transparent">
<embed src="images/newservices.swf" wmode="transparent" quality=high pluginspage="" type="application/x-shockwave-flash" width="400" height="100"></embed>

Hope this helps someone else...

yudhikk - 10/6/2004 at 05:30 AM

how about form element ? the same thing happen with form element.
Is there any clue ???

tigra - 10/6/2004 at 08:04 PM

The solution described above will only work for flash movies. You'll need Tigra Menu GOLD to make menu overlap other types of windowed controls.

LordErikS - 8/1/2006 at 02:15 PM

For FireFox, you'll also need to add the following parameter to the EMBED tag:
<embed ... wmode='transparent'>

LordErikS - 8/10/2006 at 12:10 PM

Unfortunatly the transparency solution stated above works but does not allow for the use of buttons within flash.

Does Gold allow for buttons to work? I don't want to purchase Gold and have it not work.
If it does work, is it possible to upgrade from Pro to gold?

tigra - 8/10/2006 at 05:20 PM

submit a support ticket with the flash movie in question. we'll try it and let you know.

shan - 8/30/2006 at 06:19 PM

I was having the exact same problem, but i used z-index and it worked.

LordMerlin - 9/3/2006 at 03:58 PM


Can you please tell me how you used the z-index? What is the z-index? Where do I add it?

shan - 9/13/2006 at 11:22 AM

z-index indicates the stack level of the current element's box in the current context.
Positioning of elements in CSS occurs in three dimensions. The third dimension is perpendicular to the screen, giving the screen a sense of depth.
The placement of elements along this third 'z-axis' is exactly what this property z-index controls.

I added the z-index in the menu.js file in the function menu_item, where it generates the item's html. (This is for the free version of Tigra menu.)

LordMerlin - 9/14/2006 at 02:18 AM

Ok, I understand your explination, but can you please tell me where in the .js file to put it, and what exactly to put in?

Maybe just copy & paste the extra code you added here? I'd really appreciate it :)

tigra - 9/14/2006 at 09:09 AM

just search menu.js for
z-index: ' + this.n_depth + ';"
and replace it with
z-index: ' + (this.n_depth + 1000) + ';"
where 1000 is the base offset (usually sufficient to cover other layers of the document). note that z-index is not honored by windowed controls such as selectboxes, flash movies and iframes, that's where GOLD version can help.

tigra - 2/26/2009 at 04:03 PM

To enable <param name="wmode" value="transparent"> with AC_FL_RunContent( .. ) function add
'wmode', 'transparent' at the end of the parameters list:

AC_FL_RunContent( 'codebase',',0,28,0','width','490','height','330','src','f lash/movieName','quality','high','pluginspage','','movie ','flash/movieName','wmode','transparent' );

Tanee12 - 10/8/2009 at 04:46 AM

Earlier versions of Netscape still show it behind the flash since they don't seem to be able to support transparent flash movies. So that pretty much means that any version of Netscape other than the very recent one will not show the menu, unless someone has some other suggestion.



samchn07 - 1/3/2012 at 01:11 PM

i think you should recheck all the technical aspects to form the elements and flash movies behind the menu! i am very much sure if there might have been something wrong that not keeping this form proper.

er34 - 6/8/2012 at 06:11 AM


&#12464;&#12483;&#12481; &#12496;&#12483;&#12464;
&#12464;&#12483;&#12481; &#36001;&#24067;

Back to forum: