Page 1 of 1

first image in list does not fade

PostPosted: Sat Nov 10, 2012 9:24 am
by zgrant45211
The first image in the list does not fade but remains visible behind all subsequent images. Except for setting the value of the randomizing element to false I have changed anything. Any suggestions?

Re: first image in list does not fade

PostPosted: Sat Nov 10, 2012 3:27 pm
by tigra
Do you experience this issue with the demo on the site or any of the demos in the download? Is this behavior browser specific?

Re: first image in list does not fade

PostPosted: Tue Nov 13, 2012 7:54 am
by zgrant45211
No, this does not happen with the demos. It does happen in different browsers.

Re: first image in list does not fade

PostPosted: Tue Nov 13, 2012 5:05 pm
by tigra
Start out with the working demo and gradually add features from your setup until it stops working in affected browser(s).
This way you'll now what code in your page causes the problem in fader.
Alternative approach is to use document inspector in the browser to see if elements are visible but hiding behind another element etc.

Re: first image in list does not fade

PostPosted: Thu Nov 15, 2012 10:13 am
by zgrant45211
The problem was the image file format. The fader doesn't seem to like .png files. I was surprised to find I had the same problem with .gif since the Sample2 demo includes .gif files for the number images. I just saved my .png images with cut away backgrounds to .jpg with white backgrounds and the fader worked: the first image now fades instead of remaining visible behind the succeeding images.

Thanks for your help!

Re: first image in list does not fade

PostPosted: Tue Nov 20, 2012 1:03 pm
by tigra
The script doesn't directly deal with the image formats. It only changes some CSS properties to control the visibility. PNGs and GIFs should work fine as long as browser knows how to display them and majority of them do.